Rails 1.1 and Typo PSA

If you read this and you are running Typo, I hope it helps you. I am one of the Typo Gardeners at TypoGarden. Rails 1.1 just came out and it breaks some backwards compatibility and at this time, Typo breaks when it is run with it. There is an experimental branch of Typo that hopes to fix these issues, but for now, it would be wise either not to upgrade to Rails 1.1 unless you need it, or to run

rake freeze_edge REVISION=3303

in your Typo directory so that you freeze which version of Rails (1.0) you are running until something can be done. This is particularly relevant for people on shared hosts like TextDrive or Dreamhost. This has been a PSA. We now return you to our regularly scheduled programming.

Leave a Reply

Your email address will not be published. Required fields are marked *